POSIM Mac OSX and Zebra jpeg

Using Mac & Zebra LP 2824? Please Read: Before You Upgrade to Mac OS 10.9 (Mavericks)

BEFORE YOU UPGRADE TO MAC OS 10.9 (MAVERICKS)

Apple has notified POSIM that Mac OS 10.9 has dropped support for the Zebra Non Plus LP 2824.

What does this mean?

Mavericks is not compatible with the Zebra LP 2824 printer.

What you can do if you currently own a Zebra LP 2824 and have upgraded or are interested in upgrading to Mac OS 10.9 (Mavericks):

  • Upgrade your label printer too! Mavericks is compatible with the Zebra LP 2824 Plus.
  • If you have two or more computers, you can choose to upgrade all (but one) computers to Mavericks. Keep one computer on an older operating system so it is still compatible with your Zebra LP 2824 printer.
  • If you only have one computer and it uses Mavericks OS 10.9, you can downgrade to an older operating system to remain compatible with the Zebra LP 2824 label printer.

Though this change does not involve POSIM or impact POSIM’s performance, we realize that this will impact some of our current customers. If you have additional questions please contact POSIM directly, we are happy to help! To review additional system requirements please visit our Knowledge Base page.

POSIM (800) 409-7678 or Support@POSIM.com

Menu